<!DOCTYPE html>
<html class="no-js" lang="en-CA" xmlns:fb="http://ogp.me/ns/fb#">
<head>
<meta charset="UTF-8">
<title>Drug Overdose Deaths Top Accidents, Murders and Suicides in 2019 - My Powell River Now</title>

<link href="//www.google-analytics.com" rel="dns-prefetch">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width,initial-scale=1.0,user-scalable=yes">
<link rel="shortcut icon" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png">
<link rel="apple-touch-icon" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png">
<link rel="apple-touch-icon" sizes="114x114" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png">
<link rel="apple-touch-icon" sizes="72x72" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png">
<link rel="apple-touch-icon" sizes="144x144" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png">

<meta property="og:site_name" content="My Powell River Now">
<meta property="og:url" content="https://www.mypowellrivernow.com/27061/drug-overdose-deaths-top-accidents-murders-and-suicides-in-2019/" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Drug Overdose Deaths Top Accidents, Murders and Suicides in 2019" />
<meta property="og:description" content="BC’s Coroners Service says the number of overdose deaths from illicit drugs in 2019 was higher than motor vehicle accidents, murders and ... more &#8250;">
<meta property="og:image" content="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/e-parody-3-e1579908671297.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="314" />
<script data-ad-client="ca-pub-3985045263764181" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>


<link rel="stylesheet" id="wp-forecast-css" href="https://www.mypowellrivernow.com/wp-content/plugins/wp-forecast/wp-forecast-default.css" type="text/css" media="screen" />
<script>
                            /* You can add more configuration options to webfontloader by previously defining the WebFontConfig with your options */
                            if ( typeof WebFontConfig === "undefined" ) {
                                WebFontConfig = new Object();
                            }
                            WebFontConfig['google'] = {families: ['Oswald:300,400,700', 'Open+Sans:300,400,600,700,800,300italic,400italic,600italic,700italic,800italic']};

                            (function() {
                                var wf = document.createElement( 'script' );
                                wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';
                                wf.type = 'text/javascript';
                                wf.async = 'true';
                                var s = document.getElementsByTagName( 'script' )[0];
                                s.parentNode.insertBefore( wf, s );
                            })();
                        </script>

<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.mypowellrivernow.com/27061/drug-overdose-deaths-top-accidents-murders-and-suicides-in-2019/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Drug Overdose Deaths Top Accidents, Murders and Suicides in 2019 - My Powell River Now" />
<meta property="og:description" content="BC’s Coroners Service says the number of overdose deaths from illicit drugs in 2019 was higher than motor vehicle accidents, murders and ... more &#8250;" />
<meta property="og:url" content="https://www.mypowellrivernow.com/27061/drug-overdose-deaths-top-accidents-murders-and-suicides-in-2019/" />
<meta property="og:site_name" content="My Powell River Now" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2020-02-25T21:42:03+00:00" />
<meta property="article:modified_time" content="2020-02-25T21:49:47+00:00" />
<meta property="og:updated_time" content="2020-02-25T21:49:47+00:00" />
<meta property="og:image" content="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/e-parody-3-e1579908671297.jpg" />
<meta property="og:image:secure_url" content="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/e-parody-3-e1579908671297.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="874" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.mypowellrivernow.com/#website","url":"https://www.mypowellrivernow.com/","name":"My Powell River Now","potentialAction":{"@type":"SearchAction","target":"https://www.mypowellrivernow.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.mypowellrivernow.com/27061/drug-overdose-deaths-top-accidents-murders-and-suicides-in-2019/#primaryimage","url":"https://www.mypowellrivernow.com/wp-content/uploads/2020/02/e-parody-3-e1579908671297.jpg","width":1200,"height":874},{"@type":"WebPage","@id":"https://www.mypowellrivernow.com/27061/drug-overdose-deaths-top-accidents-murders-and-suicides-in-2019/#webpage","url":"https://www.mypowellrivernow.com/27061/drug-overdose-deaths-top-accidents-murders-and-suicides-in-2019/","inLanguage":"en-CA","name":"Drug Overdose Deaths Top Accidents, Murders and Suicides in 2019 - My Powell River Now","isPartOf":{"@id":"https://www.mypowellrivernow.com/#website"},"primaryImageOfPage":{"@id":"https://www.mypowellrivernow.com/27061/drug-overdose-deaths-top-accidents-murders-and-suicides-in-2019/#primaryimage"},"datePublished":"2020-02-25T21:42:03+00:00","dateModified":"2020-02-25T21:49:47+00:00","author":{"@id":"https://www.mypowellrivernow.com/#/schema/person/f56aa71a4d18063d0f2a41b6d54be9d3"}},{"@type":["Person"],"@id":"https://www.mypowellrivernow.com/#/schema/person/f56aa71a4d18063d0f2a41b6d54be9d3","name":"Mike Patterson","image":{"@type":"ImageObject","@id":"https://www.mypowellrivernow.com/#authorlogo","url":"https://secure.gravatar.com/avatar/cbaa1d7ea8de7bf0414455ed66520352?s=96&d=mm&r=g","caption":"Mike Patterson"},"sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//ras.vistaradio.ca' />
<link rel='dns-prefetch' href='//cdn.vistaradio.ca' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="My Powell River Now &raquo; Feed" href="https://www.mypowellrivernow.com/feed/" />
<link rel="alternate" type="text/calendar" title="My Powell River Now &raquo; iCal Feed" href="https://www.mypowellrivernow.com/community-calendar/?ical=1" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.mypowellrivernow.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tribe-common-skeleton-style-css' href='https://www.mypowellrivernow.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css' href='https://www.mypowellrivernow.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css' href='https://www.mypowellrivernow.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://www.mypowellrivernow.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css' href='https://www.mypowellrivernow.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.mypowellrivernow.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-flexslider-css' href='https://www.mypowellrivernow.com/wp-content/themes/presso/framework/flexslider/flexslider-custom.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-icon-social-css' href='https://www.mypowellrivernow.com/wp-content/themes/presso/framework/font-icons/social-icons/css/zocial.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-icon-entypo-css' href='https://www.mypowellrivernow.com/wp-content/themes/presso/framework/font-icons/entypo/css/entypo.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-icon-symbol-css' href='https://www.mypowellrivernow.com/wp-content/themes/presso/framework/font-icons/symbol/css/symbol.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-swipebox-css' href='https://www.mypowellrivernow.com/wp-content/themes/presso/framework/swipebox/swipebox.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-bootstrap-css' href='https://www.mypowellrivernow.com/wp-content/themes/presso/framework/bootstrap/css/bootstrap.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='vwcss-theme-css' href='https://www.mypowellrivernow.com/wp-content/themes/presso/css/theme.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://www.mypowellrivernow.com/wp-content/themes/presso-child/style.css?ver=5.2.5' type='text/css' media='all' />
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-content/plugins/wp-forecast/wpf_update.js?ver=9999'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var instant_search = {"blog_url":"https:\/\/www.mypowellrivernow.com","ajax_url":"https:\/\/www.mypowellrivernow.com\/wp-admin\/admin-ajax.php","placeholder":"Search"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-content/themes/presso/framework/instant-search/instant-search.js?ver=2.0'></script>
<script type='text/javascript' src='https://cdn.vistaradio.ca/js/iframeResizer.js'></script>
<link rel='https://api.w.org/' href='https://www.mypowellrivernow.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mypowellrivernow.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mypowellrivernow.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.2.5" />
<link rel='shortlink' href='https://www.mypowellrivernow.com/?p=27061' />
<link rel="alternate" type="application/json+oembed" href="https://www.mypowellrivernow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mypowellrivernow.com%2F27061%2Fdrug-overdose-deaths-top-accidents-murders-and-suicides-in-2019%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mypowellrivernow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mypowellrivernow.com%2F27061%2Fdrug-overdose-deaths-top-accidents-murders-and-suicides-in-2019%2F&#038;format=xml" />
<meta property="fb:app_id" content="335982600081119" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.mypowellrivernow.com"><link rel="https://theeventscalendar.com/" href="https://www.mypowellrivernow.com/wp-json/tribe/events/v1/" /> <style id="vw-custom-font" type="text/css">
						
					</style>

<style type="text/css">
		::selection { color: white; background-color: #3facd6; }
		
		h1 { line-height: 1.1; }
		h2 { line-height: 1.2; }
		h3, h4, h5, h6 { line-height: 1.4; }

		.header-font,
		woocommerce div.product .woocommerce-tabs ul.tabs li, .woocommerce-page div.product .woocommerce-tabs ul.tabs li, .woocommerce #content div.product .woocommerce-tabs ul.tabs li, .woocommerce-page #content div.product .woocommerce-tabs ul.tabs li
		{ font-family: Oswald; font-weight: 700; }
		.header-font-color { color: #333333; }

		.wp-caption p.wp-caption-text {
			color: #333333;
			border-bottom-color: #333333;
		}
		
		.body-font { font-family: Open Sans; font-weight: 400; }

		/* Only header font, No font-weight */
		.mobile-nav,
		.top-nav,
		.comment .author > span, .pingback .author > span, 
		.label, .tagcloud a,
		.woocommerce .product_meta .post-tags a,
		.bbp-topic-tags a,
		.woocommerce div.product span.price, .woocommerce-page div.product span.price, .woocommerce #content div.product span.price, .woocommerce-page #content div.product span.price, .woocommerce div.product p.price, .woocommerce-page div.product p.price, .woocommerce #content div.product p.price, .woocommerce-page #content div.product p.price,
		.main-nav .menu-link { font-family: Oswald; }

		/* Primary Color */
		.primary-bg,
		.label, .tagcloud a,
		.woocommerce nav.woocommerce-pagination ul li span.current, .woocommerce-page nav.woocommerce-pagination ul li span.current, .woocommerce #content nav.woocommerce-pagination ul li span.current, .woocommerce-page #content nav.woocommerce-pagination ul li span.current, .woocommerce nav.woocommerce-pagination ul li a:hover, .woocommerce-page nav.woocommerce-pagination ul li a:hover, .woocommerce #content nav.woocommerce-pagination ul li a:hover, .woocommerce-page #content nav.woocommerce-pagination ul li a:hover, .woocommerce nav.woocommerce-pagination ul li a:focus, .woocommerce-page nav.woocommerce-pagination ul li a:focus, .woocommerce #content nav.woocommerce-pagination ul li a:focus, .woocommerce-page #content nav.woocommerce-pagination ul li a:focus,
		#pagination > span {
			background-color: #3facd6;
		}
		a, .social-share a:hover, .site-social-icons a:hover,
		.bbp-topic-header a:hover,
		.bbp-forum-header a:hover,
		.bbp-reply-header a:hover { color: #3facd6; }
		.button-primary { color: #3facd6; border-color: #3facd6; }
		.primary-border { border-color: #3facd6; }

		/* Top-bar Colors */
		.top-bar {
			background-color: #333333;
			color: #eeeeee;
		}

		#open-mobile-nav, .top-nav  a, .top-bar-right > a {
			color: #eeeeee;
		}

		#open-mobile-nav:hover, .top-nav  a:hover, .top-bar-right > a:hover {
			background-color: #3facd6;
			color: #ffffff;
		}

		.top-nav .menu-item:hover { background-color: #3facd6; }
		.top-nav .menu-item:hover > a { color: #ffffff; }

		/* Header Colors */
		.main-bar {
			background-color: #f9f9f9;
			color: #bbbbbb;
		}

		/* Main Navigation Colors */
		.main-nav-bar {
			background-color: #333333;
		}

		.main-nav-bar, .main-nav > .menu-item > a {
			color: #ffffff;
		}

		.main-nav .menu-item:hover > .menu-link,
		.main-nav > .current-menu-ancestor > a,
		.main-nav > .current-menu-item > a {
			background-color: #3facd6;
			color: #ffffff;
		}

		/* Widgets */
		.widget_vw_widget_social_subscription .social-subscription:hover .social-subscription-icon { background-color: #3facd6; }
		.widget_vw_widget_social_subscription .social-subscription:hover .social-subscription-count { color: #3facd6; }

		.widget_vw_widget_categories a:hover { color: #3facd6; }

		/* Footer Colors */
		#footer {
			background-color: #111111;
		}

		#footer .widget-title {
			color: #3facd6;
		}

		#footer,
		#footer .title,
		#footer .comment-author,
		#footer .social-subscription-count
		{ color: #999999; }

		.copyright {
			background-color: #000000;
		}
		.copyright, .copyright a {
			color: #dddddd;
		}

		/* Custom Styles */
					</style>
<style type="text/css" id="wp-custom-css">
			.main-nav-bar .top-bar-right > a.site-social-icon { display: none; }
		</style>
<style type="text/css" title="dynamic-css" class="options-output">h1, h2, h3, h4, h5, h6{font-family:Oswald;text-transform:uppercase;font-weight:700;font-style:700;color:#333333;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading h1, h2, h3, h4, h5, h6,{opacity: 0;}.ie.wf-loading h1, h2, h3, h4, h5, h6,{visibility: hidden;}body{font-family:"Open Sans";font-weight:400;font-style:400;color:#666666;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading body,{opacity: 0;}.ie.wf-loading body,{visibility: hidden;}</style>

<!--[if lt IE 9]>
			<script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7/html5shiv.min.js"></script>
			<script src="//cdnjs.cloudflare.com/ajax/libs/respond.js/1.3.0/respond.min.js"></script>
		<![endif]-->
<script type="text/javascript" src="/wp-content/themes/presso-child/js/jquery.ihavecookies.min.js"></script>
<script type="text/javascript">
		jQuery(document).ready(function() {
				jQuery('body').ihavecookies({
						title: 'Accept Cookies & Privacy Policy?',
						message: 'We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. By continuing to use our website you consent to our Cookie and Privacy Policy. ',
						delay: 600,
						expires: 1825,
						link: 'https://www.vistaradio.ca/privacy/',
						//onAccept: function(){
						//		alert('Yay! You clicked the accept button. This is an optional callback function that can be set on accept.');
						//},
						uncheckBoxes: true
				});
		});
		</script>
<link href="https://fonts.googleapis.com/css?family=Open+Sans" rel="stylesheet">
<style type="text/css">
		:root {
				--purple: #3B3646;
				--red: #EE4B5A;
		}
		/* Cookie Dialog */
		#gdpr-cookie-message {
				position: fixed;
				right: 30px;
				bottom: 30px;
				max-width: 375px;
				background-color: var(--purple);
				padding: 20px;
				border-radius: 5px;
				box-shadow: 0 6px 6px rgba(0,0,0,0.25);
				margin-left: 30px;
				font-family: system-ui;
		}
		#gdpr-cookie-message h4 {
				color: var(--red);
				font-family: 'Open Sans', sans-serif;
				font-size: 18px;
				font-weight: 500;
				margin: 0 0 10px;
		}
		#gdpr-cookie-message p {
				color: white;
				font-size: 15px;
				line-height: 1.5em;
		}
		#gdpr-cookie-message p:last-child {
				margin-bottom: 0;
				text-align: right;
		}
		#gdpr-cookie-message a {
				color: var(--red);
				text-decoration: none;
				font-size: 15px;
				padding-bottom: 2px;
				border-bottom: 1px dotted rgba(255,255,255,0.75);
				transition: all 0.3s ease-in;
		}
		#gdpr-cookie-message a:hover {
				color: white;
				border-bottom-color: var(--red);
				transition: all 0.3s ease-in;
		}
		#gdpr-cookie-message button {
				border: none;
				background: var(--red);
				color: white;
				font-family: 'Open Sans', sans-serif;
				font-size: 15px;
				padding: 7px;
				border-radius: 3px;
				margin-left: 15px;
				cursor: pointer;
				transition: all 0.3s ease-in;
		}
		#gdpr-cookie-message button:hover {
				background: white;
				color: var(--red);
				transition: all 0.3s ease-in;
		}
		</style>

<script>
		  var _comscore = _comscore || [];
		  _comscore.push({ c1: "2", c2: "33145398" });
		  (function() {
		    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
		    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
		    el.parentNode.insertBefore(s, el);
		  })();
		</script>
<noscript>
		  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=33145398&cv=2.0&cj=1" />
		</noscript>

</head>
<body id="top" class="post-template-default single single-post postid-27061 single-format-standard custom-background tribe-no-js tribe-theme-parent-presso tribe-theme-child-presso-child site-layout-boxed site-disable-post-box-effects">
<nav id="mobile-nav-wrapper"></nav>
<aside class="zone takeover"><ins data-revive-zoneid="116" data-revive-target="_blank" data-revive-id="b07d3d41c82582579069d81820142439"></ins></aside><div style="position: fixed; top:0px; left:0px; z-index: -1; background: url(//ras.vistaradio.ca/dist/avw.php?raszid=251) center top no-repeat; background-size: cover; width: 100%; height:100%;"><a href="//ras.vistaradio.ca/dist/ck.php?n=NID&amp;cb=RANDOM_NUMBER" target="_blank" style="display: block; width: 100%; height: 100%;"></a></div> <div id="off-canvas-body-inner">

<div id="top-bar" class="top-bar">
<div class="container">
<div class="row">
<div class="col-sm-12">
<span id="weather-ajax"></span><div class="weather-zone"><script src="/bmp-zone-weather.js"></script></div>
<script>
	jQuery.ajax({
		url : "/wp-content/themes/presso-child/vista/weather-ajax.php",
		dataType: "text",
		success : function (data) {
			if (data!="") {
				jQuery("#weather-ajax").html(data);
			}
		}
	});
	</script>
<div id="listen-live-header">
<div class="listen-live-station listen-live-link" data-stream="cfpw" id="hdr-ll-cfpw">
<div class="wrapper">
<span><img src="https://www.mypowellrivernow.com/wp-content/themes/presso-child/vista/_img/icons/play-hdr.png" alt="Listen Live to 95.7 Coast FM"></span>
<span>
<h3 class="brand-coast">95.7 Coast FM</h3>
<h4><div class="song-ticker"></div></h4>
</span>
</div>
</div>
<script>
(function($){
    $('document').ready(function() {
        $.ajax({
            url : "/stream/recentplayed.php?s=CFPW&g=OLDIES&l=1&nolist=true&ts="+ Date.now() +"",
               dataType: "text",
               cache: false,
               success : function (data) {
                if (data) {
                    $("#hdr-ll-cfpw .song-ticker").html(data);
                    $(".time").css('display','none');

                    if ($('#hdr-ll-cfpw p.artist').textWidth() + $('#hdr-ll-cfpw .title').textWidth() >= '90') {
                        $('#hdr-ll-cfpw .song-ticker').addClass('marquee');
                    }
                    //if ($('#hdr-ll-cfpw .title').textWidth() >= '80') {
                    //  $('#hdr-ll-cfpw .title').addClass('marquee');
                    //}

                }
            }
        });
    });
})(jQuery);
</script>
</div> </div>
</div>
<div class="row">
<div class="col-sm-12">
<a id="open-mobile-nav" href="#mobile-nav"><i class="icon-entypo-menu">menu</i></a>
</div>
</div>
</div>
</div>


<header class="main-bar header-layout-left-logo">
<div class="container">
<div class="row">
<div class="col-sm-12">
<div id="logo" class="" style="/*display: block; text-align: center; margin-bottom: 1em; width: 100%;*/">
<a href="https://www.mypowellrivernow.com/" style="white-space: nowrap;">
<span id="mynow-icon"><img src="https://www.mypowellrivernow.com/wp-content/themes/presso-child/vista/_img/mynow-icon.png" alt="My Powell River Now" border="0" width="63" height="63" class="logo-original" /></span>
<span id="mynow-logo"><img src="https://www.mypowellrivernow.com/wp-content/themes/presso-child/vista/_img/comm/mypowellrivernow.png" alt="My Powell River Now" border="0" width="100%" height="50" class="logo-original" /></span>
</a>
</div>
<div id="station-logo-header" style="/*display: block; text-align: center; width: 100%;*/">
<div>
<a href="https://www.mypowellrivernow.com/coast-fm/">
<img src="https://www.mypowellrivernow.com/wp-content/themes/presso-child/vista/_img/station/CFPW.png?20200214" alt="95.7 Coast FM" width="" height="" border="0" class="brand-coast" />
</a>
</div>
</div>
</div>
</div>
</div>
</header>


<div class="main-nav-bar header-layout-left-logo">
<div class="container">
<div class="row">
<div class="col-sm-12">
<div class="top-bar-right">
<a class="site-social-icon" href="https://www.facebook.com/957coastfm" title="Facebook" target="_blank"><i class="icon-social-facebook"></i></a><a class="site-social-icon" href="https://twitter.com/957CoastFM" title="Twitter" target="_blank"><i class="icon-social-twitter"></i></a> <a class="instant-search-icon" href="#menu1"><i class="icon-entypo-search"></i></a>
</div>
<nav id="main-nav-wrapper"><ul id="menu-main-navigation" class="main-nav list-unstyled"><li id="nav-menu-item-53" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children"><a href="https://www.mypowellrivernow.com/news/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-bullhorn" aria-hidden="true"></i><span>News</span></span></a><div class="sub-menu-container">
<ul class="sub-menu menu-odd  menu-depth-1">
<li id="nav-menu-item-55" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://www.mypowellrivernow.com/news/" class="menu-link sub-menu-link"><span>Powell River News</span></a></li>
<li id="nav-menu-item-25000" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mypowellrivernow.com/news/2019-federal-elections/" class="menu-link sub-menu-link"><span>2019 Federal Elections</span></a></li>
<li id="nav-menu-item-56" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mypowellrivernow.com/submit-news-tip/" class="menu-link sub-menu-link"><span>Submit News Tip</span></a></li>
</ul>
</li>
<li id="nav-menu-item-4669" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mypowellrivernow.com/win/" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-smiley" aria-hidden="true"></i><span>Win</span></span></a><div class="sub-menu-container"></li>
<li id="nav-menu-item-52" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="/community-calendar/" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-calendar" aria-hidden="true"></i><span>Events</span></span></a>
<ul class="sub-menu menu-odd  menu-depth-1">
<li id="nav-menu-item-2120" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="/community-calendar/" class="menu-link sub-menu-link"><span>View Calendar</span></a></li>
<li id="nav-menu-item-2119" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="/community-calendar/community/add" class="menu-link sub-menu-link"><span>Submit Event</span></a></li>
</ul>
</li>
<li id="nav-menu-item-63" class="main-menu-item  menu-item-even menu-item-depth-0 nav-listen-live-link menu-item menu-item-type-custom menu-item-object-custom"><a rel="cfpw" href="#" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-play-alt" aria-hidden="true"></i><span>Listen Live</span></span></a></li>
<li id="nav-menu-item-4814" class="main-menu-item  menu-item-even menu-item-depth-0 menu-icon-on-air menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.mypowellrivernow.com/on-air/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-microphone" aria-hidden="true"></i><span>On Air</span></span></a><div class="sub-menu-container">
<ul class="sub-menu menu-odd  menu-depth-1">
<li id="nav-menu-item-4815" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mypowellrivernow.com/on-air/" class="menu-link sub-menu-link"><span>Shows &#038; More</span></a></li>
<li id="nav-menu-item-4813" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mypowellrivernow.com/coast-fm/" class="menu-link sub-menu-link"><span>Talent</span></a></li>
<li id="nav-menu-item-4816" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mypowellrivernow.com/contact-us/" class="menu-link sub-menu-link"><span>Contact Us</span></a></li>
</ul>
</li>
<li id="nav-menu-item-17600" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-ship" aria-hidden="true"></i><span>Ferry Report</span></span></a>
<ul class="sub-menu menu-odd  menu-depth-1">
<li id="nav-menu-item-17603" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a target="_blank" href="https://www.bcferries.com/schedules/mainland/copr-current.php" class="menu-link sub-menu-link"><span>Powell River &#8211; Comox</span></a></li>
<li id="nav-menu-item-17601" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a target="_blank" href="https://www.bcferries.com/schedules/northern/prti-current.php" class="menu-link sub-menu-link"><span>Powell River &#8211; Texada Island</span></a></li>
<li id="nav-menu-item-17602" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a target="_blank" href="https://www.bcferries.com/schedules/mainland/sepr-current.php" class="menu-link sub-menu-link"><span>Powell River &#8211; Sechelt</span></a></li>
</ul>
</li>
<li id="nav-menu-item-17959" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mypowellrivernow.com/local-connections/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-star" aria-hidden="true"></i><span>Local Connections</span></span></a><div class="sub-menu-container"></li>
</ul></nav>
</div>
</div>
</div>
</div>

<div id="page-wrapper" class="container">
<div class="row">
<div id="page-content" class="col-sm-7 col-md-8">
<article id="post-27061" class="post-27061 post type-post status-publish format-standard has-post-thumbnail hentry category-news">
<div class="z1"><script src="/bmp-zone1.js"></script></div> <div class="tags clearfix">
<a class="label " href="https://www.mypowellrivernow.com/news/" title="View all posts in News" rel="category">News</a> </div>
<h1 class="post-title title title-large entry-title">Drug Overdose Deaths Top Accidents, Murders and Suicides in 2019</h1>
<hr class="hr-thin-bottom">
<div class="social-share">
<span class="header-font">SHARE ON:</span>
<a class="social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mypowellrivernow.com%2F27061%2Fdrug-overdose-deaths-top-accidents-murders-and-suicides-in-2019%2F&amp;t=http://Drug%20Overdose%20Deaths%20Top%20Accidents,%20Murders%20and%20Suicides%20in%202019" title="Share on Facebook" target="_blank"><i class="icon-social-facebook"></i></a>
<a class="social-twitter" href="https://twitter.com/share?text=Drug+Overdose+Deaths+Top+Accidents%2C+Murders+and+Suicides+in+2019&url=https%3A%2F%2Fwww.mypowellrivernow.com%2F27061%2Fdrug-overdose-deaths-top-accidents-murders-and-suicides-in-2019%2F" title="Share on Twitter" target="_blank"><i class="icon-social-twitter"></i></a>
<a class="social-googleplus" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.mypowellrivernow.com%2F27061%2Fdrug-overdose-deaths-top-accidents-murders-and-suicides-in-2019%2F" title="Share on Google+" target="_blank"><i class="icon-social-gplus"></i></a>
<a class="social-pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mypowellrivernow.com%2F27061%2Fdrug-overdose-deaths-top-accidents-murders-and-suicides-in-2019%2F&amp;media=https://www.mypowellrivernow.com/wp-content/uploads/2020/02/e-parody-3-e1579908671297.jpg&amp;description=http://Drug%20Overdose%20Deaths%20Top%20Accidents,%20Murders%20and%20Suicides%20in%202019" title="Share on Pinterest" target="_blank"><i class="icon-social-pinterest"></i></a>
</div>
<div class="post-meta header-font">
<img src="https://secure.gravatar.com/avatar/cbaa1d7ea8de7bf0414455ed66520352?s=48&#038;d=mm&#038;r=g" width="48" height="48" alt="Avatar" class="avatar avatar-48 wp-user-avatar wp-user-avatar-48 photo avatar-default" /> <a class="author-name vcard author" href="https://www.mypowellrivernow.com/talent/mike/" title="View all posts by Mike Patterson"><span class="fn">Mike Patterson</span></a><span class="post-meta-separator">,</span>
<span class="label-staff">staff</span><span class="post-meta-separator"></span>
<a href="https://www.mypowellrivernow.com/27061/drug-overdose-deaths-top-accidents-murders-and-suicides-in-2019/" class="post-date updated" title="Permalink to Drug Overdose Deaths Top Accidents, Murders and Suicides in 2019" rel="bookmark">Tuesday, Feb. 25th, 2020</a>
</div>
<div class="post-thumbnail-wrapper">
<a class="swipebox" href="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/e-parody-3-e1579908671297.jpg" title="Permalink to image of Drug Overdose Deaths Top Accidents, Murders and Suicides in 2019" rel="bookmark">
<img width="750" height="420" src="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/e-parody-3-e1579908671297-750x420.jpg" class="attachment-vw_medium size-vw_medium wp-post-image" alt="" srcset="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/e-parody-3-e1579908671297-750x420.jpg 750w, https://www.mypowellrivernow.com/wp-content/uploads/2020/02/e-parody-3-e1579908671297-265x147.jpg 265w" sizes="(max-width: 750px) 100vw, 750px" />
</a>
<div class="vw-featured-image-caption-wrapper">
<div class="vw-featured-image-caption">
<i class="icon-entypo-camera"></i> Baggies of street level fentanyl (Supplied by the RCMP) </div>
</div>
</div>
<div class="post-content clearfix">
<p>BC’s Coroners Service says the number of overdose deaths from illicit drugs in 2019 was higher than motor vehicle accidents, murders and suicides combined.</p>
<p>The Coroners Service reports 981 fatal overdose deaths in 2019. While the death rate last year was 36-percent below 2018, the number is virtually identical to 2016, the year BC declared a health emergency over the deaths from street drugs.</p>
<p>Last year’s statistic represents an average of almost three people dying of drug overdoses each day.</p>
<p>Chief Coroner Lisa Lapointe says more than five-thousand people have died from overdoses since 2016. Lapointe says families are deeply hurt and communities suffer a loss of immense potential in all walks of life.</p>
<p>The BC Coroners Service and partners are renewing calls for improved access to regulated, safer drug supplies in the province.</p>
<div class="z1"><script src="/bmp-zone1.js"></script></div><div class="fb-comments-box"><div class="fb-comments" data-href="https://www.mypowellrivernow.com/27061/drug-overdose-deaths-top-accidents-murders-and-suicides-in-2019/" data-num-posts="5" data-width="100%" data-colorscheme="light"></div></div> </div>
</article>
<hr class="hr-thin-bottom">
<div class="z1"><script src="/bmp-zone1.js"></script></div>
<div class="post-related section-container clearfix">
<h2 class="section-title">Recent Posts</h2>
<div class="row">
<div class="post-box-wrapper col-sm-6 col-md-4 ">
<article class="post-27065 post-box post-box-headline">
<h3 class="title title-small"><a href="https://www.mypowellrivernow.com/27065/mp-blaney-says-federal-ndps-pharmacare-act-will-save-billions/" title="Permalink to MP Blaney says federal NDP’s Pharmacare Act will save billions" rel="bookmark">MP Blaney says federal NDP’s Pharmacare Act will save billions</a></h3>
<div class="post-meta header-font">
<a href="https://www.mypowellrivernow.com/27065/mp-blaney-says-federal-ndps-pharmacare-act-will-save-billions/" class="post-date" title="Permalink to MP Blaney says federal NDP’s Pharmacare Act will save billions" rel="bookmark">Tuesday, Feb. 25th, 2020</a>
</div>
<div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.mypowellrivernow.com/27065/mp-blaney-says-federal-ndps-pharmacare-act-will-save-billions/" title="Permalink to MP Blaney says federal NDP’s Pharmacare Act will save billions" rel="bookmark">
<img width="265" height="147" src="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/IMG_2656-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" srcset="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/IMG_2656-265x147.jpg 265w, https://www.mypowellrivernow.com/wp-content/uploads/2020/02/IMG_2656-360x200.jpg 360w, https://www.mypowellrivernow.com/wp-content/uploads/2020/02/IMG_2656-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" /> </a>
</div>
</article>
</div>
<div class="post-box-wrapper col-sm-6 col-md-4 ">
<article class="post-27053 post-box post-box-headline">
<h3 class="title title-small"><a href="https://www.mypowellrivernow.com/27053/island-coastal-economic-trust-accepting-economic-project-applications/" title="Permalink to Island Coastal Economic Trust accepting economic project applications" rel="bookmark">Island Coastal Economic Trust accepting economic project applications</a></h3>
<div class="post-meta header-font">
<a href="https://www.mypowellrivernow.com/27053/island-coastal-economic-trust-accepting-economic-project-applications/" class="post-date" title="Permalink to Island Coastal Economic Trust accepting economic project applications" rel="bookmark">Monday, Feb. 24th, 2020</a>
</div>
<div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.mypowellrivernow.com/27053/island-coastal-economic-trust-accepting-economic-project-applications/" title="Permalink to Island Coastal Economic Trust accepting economic project applications" rel="bookmark">
<img width="265" height="147" src="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/49323231_2036228746442622_1316637385823354880_n-750x420-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" srcset="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/49323231_2036228746442622_1316637385823354880_n-750x420-265x147.jpg 265w, https://www.mypowellrivernow.com/wp-content/uploads/2020/02/49323231_2036228746442622_1316637385823354880_n-750x420-300x168.jpg 300w, https://www.mypowellrivernow.com/wp-content/uploads/2020/02/49323231_2036228746442622_1316637385823354880_n-750x420-360x200.jpg 360w, https://www.mypowellrivernow.com/wp-content/uploads/2020/02/49323231_2036228746442622_1316637385823354880_n-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" /> </a>
</div>
</article>
</div>
<div class="post-box-wrapper col-sm-6 col-md-4 hidden-sm">
<article class="post-27050 post-box post-box-headline">
<h3 class="title title-small"><a href="https://www.mypowellrivernow.com/27050/bc-ferries-announces-new-cfo/" title="Permalink to BC Ferries announces new CFO" rel="bookmark">BC Ferries announces new CFO</a></h3>
<div class="post-meta header-font">
<a href="https://www.mypowellrivernow.com/27050/bc-ferries-announces-new-cfo/" class="post-date" title="Permalink to BC Ferries announces new CFO" rel="bookmark">Monday, Feb. 24th, 2020</a>
</div>
<div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.mypowellrivernow.com/27050/bc-ferries-announces-new-cfo/" title="Permalink to BC Ferries announces new CFO" rel="bookmark">
<img width="265" height="147" src="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/Jill-Sharland-Photo-e1582591266843-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" srcset="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/Jill-Sharland-Photo-e1582591266843-265x147.jpg 265w, https://www.mypowellrivernow.com/wp-content/uploads/2020/02/Jill-Sharland-Photo-e1582591266843-357x200.jpg 357w" sizes="(max-width: 265px) 100vw, 265px" /> </a>
</div>
</article>
</div>
</div>
</div>

</div>
<aside id="page-sidebar" class="sidebar-wrapper col-sm-5 col-md-4">
<div class="sidebar-inner">
<div id="text-5" class="widget vw-sidebar-blog widget_text"> <div class="textwidget"><div class="z2 va-side"><script src="/bmp-zone2.js"></script></div></div>
</div><div id="vw_widget_post_slider-5" class="widget vw-sidebar-blog widget_vw_widget_post_slider"><h3 class="widget-title"><span class="super-title">Sponsored Articles</span>Local Connections</h3><div class="post-box-list"><div class="flexslider no-control-nav post-slider">
<ul class="slides">
<li>
<a href="https://www.mypowellrivernow.com/23726/keeping-your-dog-cool/" title="Permalink to Keeping Your Dog Cool" rel="bookmark">
<div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mypowellrivernow.com/wp-content/uploads/2019/07/mother-nature-295064-8x4-July-1.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mypowellrivernow.com/wp-content/uploads/2019/07/mother-nature-295064-8x4-July-1.jpg 810w, https://www.mypowellrivernow.com/wp-content/uploads/2019/07/mother-nature-295064-8x4-July-1-300x167.jpg 300w, https://www.mypowellrivernow.com/wp-content/uploads/2019/07/mother-nature-295064-8x4-July-1-768x427.jpg 768w, https://www.mypowellrivernow.com/wp-content/uploads/2019/07/mother-nature-295064-8x4-July-1-265x147.jpg 265w, https://www.mypowellrivernow.com/wp-content/uploads/2019/07/mother-nature-295064-8x4-July-1-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /> </div>
<div class="">
<h3 class="title">

<span>Keeping Your Dog Cool</span>
</h3>

</div>
</a>
</li>
<li>
<a href="https://www.mypowellrivernow.com/23152/hanging-baskets-tips-for-care-from-mother-nature/" title="Permalink to Hanging Baskets: Tips for Care from Mother Nature" rel="bookmark">
<div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mypowellrivernow.com/wp-content/uploads/2019/06/mother-nature-lc-8x4.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mypowellrivernow.com/wp-content/uploads/2019/06/mother-nature-lc-8x4.jpg 810w, https://www.mypowellrivernow.com/wp-content/uploads/2019/06/mother-nature-lc-8x4-300x167.jpg 300w, https://www.mypowellrivernow.com/wp-content/uploads/2019/06/mother-nature-lc-8x4-768x427.jpg 768w, https://www.mypowellrivernow.com/wp-content/uploads/2019/06/mother-nature-lc-8x4-265x147.jpg 265w, https://www.mypowellrivernow.com/wp-content/uploads/2019/06/mother-nature-lc-8x4-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /> </div>
<div class="">
<h3 class="title">

<span>Hanging Baskets: Tips for Care from Mother Nature</span>
</h3>

</div>
</a>
</li>
<li>
<a href="https://www.mypowellrivernow.com/22368/dogs-have-their-own-language/" title="Permalink to Dogs have their own language" rel="bookmark">
<div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mypowellrivernow.com/wp-content/uploads/2019/04/mother-nature-295064-8x4-Apr.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mypowellrivernow.com/wp-content/uploads/2019/04/mother-nature-295064-8x4-Apr.jpg 810w, https://www.mypowellrivernow.com/wp-content/uploads/2019/04/mother-nature-295064-8x4-Apr-300x167.jpg 300w, https://www.mypowellrivernow.com/wp-content/uploads/2019/04/mother-nature-295064-8x4-Apr-768x427.jpg 768w, https://www.mypowellrivernow.com/wp-content/uploads/2019/04/mother-nature-295064-8x4-Apr-265x147.jpg 265w, https://www.mypowellrivernow.com/wp-content/uploads/2019/04/mother-nature-295064-8x4-Apr-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /> </div>
<div class="">
<h3 class="title">

<span>Dogs have their own language</span>
</h3>

</div>
</a>
</li>
<li>
<a href="https://www.mypowellrivernow.com/21693/berries-berries-more-berries/" title="Permalink to Berries Berries &#038; More Berries" rel="bookmark">
<div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mypowellrivernow.com/wp-content/uploads/2019/03/Mother-Nature-Berries-LC-8x4.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mypowellrivernow.com/wp-content/uploads/2019/03/Mother-Nature-Berries-LC-8x4.jpg 810w, https://www.mypowellrivernow.com/wp-content/uploads/2019/03/Mother-Nature-Berries-LC-8x4-300x167.jpg 300w, https://www.mypowellrivernow.com/wp-content/uploads/2019/03/Mother-Nature-Berries-LC-8x4-768x427.jpg 768w, https://www.mypowellrivernow.com/wp-content/uploads/2019/03/Mother-Nature-Berries-LC-8x4-265x147.jpg 265w, https://www.mypowellrivernow.com/wp-content/uploads/2019/03/Mother-Nature-Berries-LC-8x4-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /> </div>
<div class="">
<h3 class="title">

<span>Berries Berries &#038; More Berries</span>
</h3>

</div>
</a>
</li>
<li>
<a href="https://www.mypowellrivernow.com/20876/beautify-your-living-space-with-unique-gift-ideas-home-decor-tropical-plants/" title="Permalink to Beautify your living space with unique Gift Ideas, Home Decor &#038; Tropical Plants." rel="bookmark">
<div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mypowellrivernow.com/wp-content/uploads/2019/03/Mother-Nature-LC-8x4-March.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mypowellrivernow.com/wp-content/uploads/2019/03/Mother-Nature-LC-8x4-March.jpg 810w, https://www.mypowellrivernow.com/wp-content/uploads/2019/03/Mother-Nature-LC-8x4-March-300x167.jpg 300w, https://www.mypowellrivernow.com/wp-content/uploads/2019/03/Mother-Nature-LC-8x4-March-768x427.jpg 768w, https://www.mypowellrivernow.com/wp-content/uploads/2019/03/Mother-Nature-LC-8x4-March-265x147.jpg 265w, https://www.mypowellrivernow.com/wp-content/uploads/2019/03/Mother-Nature-LC-8x4-March-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /> </div>
<div class="">
<h3 class="title">

<span>Beautify your living space with unique Gift Ideas, Home Decor &#038; Tropical Plants.</span>
</h3>

</div>
</a>
</li>
</ul>
</div></div></div><div id="text-6" class="widget vw-sidebar-blog widget_text"> <div class="textwidget"><div class="v-side v-promotional-carousel"><div class="v-side v-promotional"><ol><li><img src="https://www.mypowellrivernow.com/wp-content/plugins/vista-addons/img/facebook-contest-like-300x90.gif"></li></ol></div></div></div>
</div><div id="text-7" class="widget vw-sidebar-blog widget_text"> <div class="textwidget"><div class="z2 va-side"><script src="/bmp-zone2.js"></script></div></div>
</div><div id="text-19" class="widget vw-sidebar-blog widget_text"> <div class="textwidget"><div class="v-tall-side v-promotional-carousel"><div class="v-tall-side v-promotional"><ol><li><a href="https://www.mypowellrivernow.com/26865/winner-winner-chicken-dinner-sweepstakes/"><img src="https://www.mypowellrivernow.com/wp-content/uploads/2020/02/winner-winner-chicken-dinner-300x525.jpg" width="300" height="525"></a></li></ol></div></div></div>
</div><div id="text-20" class="widget vw-sidebar-blog widget_text"> <div class="textwidget"><div class="z2 va-side"><script src="/bmp-zone2.js"></script></div></div>
</div></div> </aside>
</div>
</div>
<footer id="footer">
<div id="footer-nav">
<div class="container">
<div class="row">
<div class="col-sm-5">

<div class="v-footer-menu"><ul id="menu-footer" class="menu"><li id="menu-item-67" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-67"><a href="https://www.mypowellrivernow.com/news/">News</a></li>
<li id="menu-item-4668" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4668"><a href="https://www.mypowellrivernow.com/win/">Win</a></li>
<li id="menu-item-66" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66"><a href="/community-calendar/">Events</a></li>
<li id="menu-item-70" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70"><a href="https://www.mypowellrivernow.com/contact-us/">Contact Us</a></li>
<li id="menu-item-69" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69"><a href="https://www.mypowellrivernow.com/advertise-us/">Advertise</a></li>
<li id="menu-item-4667" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4667"><a href="http://www.vistaradio.ca/about/working-at-vista/">Careers</a></li>
</ul></div> <div class="v-policy-menu">
<ul id="menu-policy-menu" class="menu">

<li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.vistaradio.ca/privacy" target="_blank">Privacy Policy</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.vistaradio.ca/terms-of-service/" target="_blank">Terms Of Service</a></li>

</ul>
</div>
</div>
</div>
</div>
</div>
<div class="copyright">
<div class="container">
<div class="row">
<div class="col-sm-6 copyright-left">
<a href="http://www.vistaradio.ca" target="_blank"><img src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/vista-logo-footer.png" width="86" height="30" border="0" alt="Powered by Vista Radio" /></a>
</div>
<div class="col-sm-6 copyright-right">
<a href="http://radioplayer.vistaradio.ca" target="_blank"><img width="107" height="30" style="width:107px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/rpc-logo-w30.png"></a>
&nbsp;
<a href="https://itunes.apple.com/ca/app/radioplayer-canada/id1204742241" target="_blank"><img width="101" height="30" style="width:101px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/get-on-itunes1.png"></a>
&nbsp;
<a href="https://play.google.com/store/apps/details?id=ca.radioplayer.android" target="_blank"><img width="101" height="30" style="width:101px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/get-on-play1.png"></a>
</div>
</div>
</div>
</div>
</footer>
</div> 
<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script type='text/javascript' src='https://www.mypowellrivernow.com/wp-content/plugins/vista-addons/_inc/../js/bounce-timers.js?ver=5.2.5'></script>
<script type='text/javascript' src='https://ras.vistaradio.ca/dist/asyncj.php?ver=5.2.5'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-includes/js/jquery/ui/effect-fade.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-content/plugins/presso-shortcodes/js/presso-shortcodes.js?ver=2.0'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-content/themes/presso/js/jquery.fitvids.js?ver=2.0'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-content/themes/presso/js/jquery.isotope.min.js?ver=2.0'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-content/themes/presso/framework/flexslider/jquery.flexslider.js?ver=2.0'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-content/themes/presso/framework/swipebox/jquery.swipebox.min.js?ver=2.0'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-content/themes/presso/js/asset.js?ver=2.0'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-content/themes/presso/js/main.js?ver=2.0'></script>
<script type='text/javascript' src='//cdn.vistaradio.ca/wp-content/themes/presso-child/js/custom.js?ver=5.2.5'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-includes/js/wp-embed.min.js?ver=5.2.5'></script>
<script type='text/javascript' src='https://www.mypowellrivernow.com/wp-content/plugins/vista-addons/js/promotional-carousel.js?ver=5.2.5'></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-56914607-20', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script> <script type='text/javascript'>
			;(function( $, window, document, undefined ){
				"use strict";

				$( document ).ready( function ($) {
							$( '.flexslider' ).flexslider({
			animation: "fade",
			easing: "easeInCirc",
			slideshow: true,
			slideshowSpeed: 4000,
			animationSpeed: 600,
			randomize: false,
			pauseOnHover: true,
			prevText: '',
			nextText: '',
			start: function( slider ) {
				slider.css( 'opacity', '1' );
				slider.find( '.post-thumbnail-wrapper' ).css( 'height', '500px' ).imgLiquid().fadeIn(250);
			},
		});
					} );
				
			})( jQuery, window , document );

					</script>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=335982600081119&version=v2.3&";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<style>.main-nav {margin-top:-25px !important;}</style>
</body>
</html>


